ET on Ubuntu (New)

All things related to Enemy Territory game. Maps, mods, scripts etc.

ET on Ubuntu (New)

Postby BigKiller » 03 May 2009, 09:56

Hey all

Happened when I installed the "new" Ubuntu 9.04 and I am not the only one with the problem, so DON'T upgrade until we get it working is my advise.

I have )=(/&%¤¤(% no back up and have lost my ET files again again... :/

Hopping to getting back playing with all of you asap!

----- FS_Startup -----
Current search path:
/home/joaquin/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak2.pk3 (22 files)
/usr/local/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (6 files)
/usr/local/games/enemy-territory/etmain

----------------------
3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 1
Minor opcode of failed request: 0
Serial number of failed request: 41
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 18
Minor opcode of failed request: 0
Serial number of failed request: 42
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 18
Minor opcode of failed request: 0
Serial number of failed request: 43
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 8
Minor opcode of failed request: 0
Serial number of failed request: 44
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 12
Minor opcode of failed request: 0
Serial number of failed request: 45
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 18
Minor opcode of failed request: 0
Serial number of failed request: 48
X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 136
Minor opcode of failed request: 7
Serial number of failed request: 53
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 154
Minor opcode of failed request: 26
Serial number of failed request: 53
Received signal 11, exiting...
Segmentation fault
joaquin@compaq:~$
Last edited by BigKiller on 20 Oct 2010, 14:57, edited 1 time in total.
BigKiller
 
Cash on hand: Locked
Bank: Locked

Re: ...

Postby BigKiller » 03 May 2009, 22:40

Sadly I am here to inform you, that the only solution I've found so far - is to format the disk, and downgrade to intrepid (Ubuntu 8.10). (bye bye 10 sec boot time :cry:)

I hope someone will find a better solution, until then - I will be using Ubuntu 8.10 :geek:

// Big Killer
BigKiller
 
Cash on hand: Locked
Bank: Locked

Re: ...

Postby Endgegner » 04 May 2009, 00:50

Hi Big Killer!

Hmm...i cant help in this case, wait for woot maye he know something!

I use Vista and i hate it! :geek:
Image
User avatar
Endgegner
 
Posts: 729
Joined: 28 Jan 2009, 18:18
Cash on hand: 0.00
Location: Space

Re: ...

Postby ETc|w00t! » 05 May 2009, 00:15

What about downgrading X, can you do it?
User avatar
ETc|w00t!
ETc| Member
 
Posts: 177
Joined: 09 Mar 2009, 21:17
Cash on hand: 0.00
Location: Afghanistan

Re: ...

Postby BigKiller » 05 May 2009, 18:18

I done that... :/
BigKiller
 
Cash on hand: Locked
Bank: Locked

Re: ...

Postby ETc|w00t! » 05 May 2009, 21:57

You can try to catch me on MSN. And if we make any progress we'll inform you guys.
User avatar
ETc|w00t!
ETc| Member
 
Posts: 177
Joined: 09 Mar 2009, 21:17
Cash on hand: 0.00
Location: Afghanistan

Re: ...

Postby ETc|^SerDrake » 05 May 2009, 22:49

.
Last edited by ETc|^SerDrake on 04 Dec 2016, 17:57, edited 1 time in total.
User avatar
ETc|^SerDrake
ETc| Member
 
Posts: 1448
Joined: 24 Apr 2009, 23:12
Cash on hand: 751.00

Re: ...

Postby ETc|KrAtoS » 07 May 2009, 11:25

BigKiller wrote:Hey all

Happened when I installed the "new" Ubuntu 9.04 and I am not the only one with the problem, so DON'T upgrade until we get it working is my advise.

I have )=(/&%¤¤(% no back up and have lost my ET files again again... :/

Hopping to getting back playing with all of you asap!

----- FS_Startup -----
Current search path:
/home/joaquin/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak2.pk3 (22 files)
/usr/local/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (6 files)
/usr/local/games/enemy-territory/etmain

----------------------
3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 1
Minor opcode of failed request: 0
Serial number of failed request: 41
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 18
Minor opcode of failed request: 0
Serial number of failed request: 42
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 18
Minor opcode of failed request: 0
Serial number of failed request: 43
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 8
Minor opcode of failed request: 0
Serial number of failed request: 44
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 12
Minor opcode of failed request: 0
Serial number of failed request: 45
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 18
Minor opcode of failed request: 0
Serial number of failed request: 48
X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 136
Minor opcode of failed request: 7
Serial number of failed request: 53
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 154
Minor opcode of failed request: 26
Serial number of failed request: 53
Received signal 11, exiting...
Segmentation fault
joaquin@compaq:~$


Killer dont use Ubuntu ;) ;) try OpenSuse 11.1 thats no problem with ET trust me i work with linux more than windows :mrgreen: :mrgreen:
User avatar
ETc|KrAtoS
ETc| Member
 
Posts: 115
Joined: 02 Jun 2008, 23:16
Cash on hand: 0.00
Location: Aschaffenburg

Re: ET on Ubuntu 9.04

Postby BigKiller » 29 Jul 2010, 23:31

I am on, with some bugs.. But I can play now on Ubuntu :D
BigKiller
 
Cash on hand: Locked
Bank: Locked

Re: ET on Ubuntu 9.04

Postby *0P*.! » 30 Jul 2010, 22:25

i had same prob bk but but i had backup files in win. Just my ubuntu dont work anymore :cry: but win working fine :D
ETc|clan forever
User avatar
*0P*.!
ETc| Member
 
Posts: 936
Joined: 28 Oct 2009, 11:04
Cash on hand: 0.00

Re: ET on Ubuntu 9.04

Postby BigKiller » 20 Oct 2010, 14:57

:S My sound is gone and it went away when I upgrade to 10.10 so downgraded it to 10.04 and the sound worked, but now ****** is gone again :/

Anyone can tell me a solution to this? (:
BigKiller
 
Cash on hand: Locked
Bank: Locked

Re: ET on Ubuntu (New)

Postby *0P*.! » 14 Apr 2011, 13:41

ubuntu 10.10 working fine now and let me know i u dont have sound whit et or use google.
ETc|clan forever
User avatar
*0P*.!
ETc| Member
 
Posts: 936
Joined: 28 Oct 2009, 11:04
Cash on hand: 0.00

Ubuntu 10.10 ET sound fix.

Postby BigKiller » 18 Apr 2011, 15:39

I did find a solution to the sound problem (also called the et-sdl-sound fix)

Run this command in the terminal:

wget -q -O - http://nullkey.kapsi.fi/et-sdl-sound/et-sdl-sound.gz | gzip -d > et-sdl-sound && chmod a+x et-sdl-sound

and then make a symbol link to the file

/home/yourusername//et-sdl-sound

enjoy.
BigKiller
 
Cash on hand: Locked
Bank: Locked

Re: ET on Ubuntu (New)

Postby *0P*.! » 18 Apr 2011, 19:16

i used that one not the best sound but better then nothing.
http://www.hirntot.org/distribution/vie ... =32&t=1126
http://www.hirntot.org/distribution/vie ... =15&t=1074
Edit: oops its same tnx bk :D
ETc|clan forever
User avatar
*0P*.!
ETc| Member
 
Posts: 936
Joined: 28 Oct 2009, 11:04
Cash on hand: 0.00


Return to Enemy Territory

Who is online

Users browsing this forum: No registered users and 2 guests

cron